Ankündigung

Einklappen
Keine Ankündigung bisher.

database error during contrexx 4.0 to 5.0.1 upgrade

Einklappen
X
  • Filter
  • Zeit
  • Anzeigen
Alles löschen
neue Beiträge

  • database error during contrexx 4.0 to 5.0.1 upgrade

    Hello world

    My provider, 1and1, no longer ensure the maintenance of PHP5
    I used Contrexx4.0 with php5.6 and sql 5.5. Contrexx5 need sql >5.6
    I have created a new database sql 5.7
    My website under Contrexx 4.0 is working well under php 5.6 and my new database 5.7.
    I am now able to makes the update to Contrexx 5.0.2 (with PHP 7.2).
    But after one minute I have this database write error (see below)
    I did two tests (after datas restoring) but I got the same error message twice.

    My provider says : “.. À partir de la version PHP 5.5, il est recommandé d'utiliser MySQLi en guise d'alternative... »
    “Starting from PHP 5.5, it is recommended to use MySQLi as an alternative ... "
    I don’t know why my provider says that. If this requirement is general or specific to ionos1and1

    Does contrexx5 use MySQLi ?

    “Datenbank Fehler bei folgendem SQL Ausdruck:
    CREATE TABLE `contrexx_module_news_settings_clean` SELECT * FROM `contrexx_module_news_settings`”

    The software cannot create a table. Is this the first write request in my database ?

    Is it better to do the first update with 5.0 then after with 5.02 ?

    Thanks for your help and your advice


    error message:

    Datenbank Fehler bei folgendem SQL Ausdruck:
    CREATE TABLE `contrexx_module_news_settings_clean` SELECT * FROM `contrexx_module_news_settings`

    Detailierte Informationen:
    Versuchen Sie das Update erneut auszuführen.

    Sollte derselbe Fehler wieder erscheinen, suchen Sie im Cloudrexx OpenSource Forum nach weiteren Hilfestellungen zu diesem Fehler.
    Falls diesbezüglich nichts bekannt ist, melden Sie dort den Fehler mit den folgenden Angaben:

    Installierte Version: 4.0.0
    Update Version:
    Info: Beim Aktualisieren der Komponente news.php trat ein Fehler auf.
    Fehlermeldung:
    Datenbank Fehler bei folgendem SQL Ausdruck:
    CREATE TABLE `contrexx_module_news_settings_clean` SELECT * FROM `contrexx_module_news_settings`

    Detailierte Informationen:



  • #2
    Hallo,

    erst mal Willkommen hier im KundenhelfenKunden-Forum :-)

    Zu Deiner Fehlermeldung habe ich nichts gefunden, aber ist der Server wirklich auf PHP7 umgestellt??? 1und1 , bzw. die Meldung weist auf was von PHP5 hin.

    Es gibt einige Zusatzeinstellungen, die man ggf. bei PHP noch von Hand vornehmen muss. Ich habe auch ein paar Sachen manuell aktivieren müssen, ehe die V5 lief.
    Inwiefern kommst Du an die einzelnen in den PHP-Einstellungen? zb. muss auch "intl" aktiviert sein. Sonst geht nichts.

    Was sagt denn die Überprüfung der Systemvoraussetzung bei Aufruf, bzw. Beginn des Updates...
    s. Link: --> https://wiki.cloudrexx.com/Knowledge...manforderungen


    ######################## IN ENGLISH ##############################

    Hello,

    First of all, welcome here in the customer help customer forum :-)

    I have found nothing to your error message, but is the Seerver really switched to PHP7, because 1und1, or the message pointing out what PHP5.

    There are some additional settings that you may still need to do manually with PHP. I also had to manually activate 2, 3 things before the V5 ran.
    How do you get to the individual in the PHP settings? eg. must also be activated "intl". Otherwise nothing works.

    What does the review of the system requirement when calling, or beginning of the update says ...
    s. Link: -> https://wiki.cloudrexx.com/Knowledge...manforderungen

    #######################

    Thomas daeppen
    Michael ritt0r
    Viele Grüße Markus
    ... der Römer aus dem ältesten Dorf "Krefeld´s" :-)


    Kenne contrexx V.1, V.2, V.3, V.4... | ... und ab sofort auch V.5 :-)

    Offizieller "cloudrexx Partner" :-)

    Kommentar


    • #3
      Hallo MK70

      Vielen Dank für Ihre Antwort (mein Deutsch ist schlecht, aber ich kann es verstehen, ich denke, es ist bequemer für Sie, die Deutsche Sprache zu verwenden.) Überprüfung der Systemvoraussetzung bei Aufruf : Alles ist in ordnung Systemanforderungen

      PHP >= 7.0 7.2.16
      MySQL/MariaDB >= 5.6 5.7.23
      GD >= 2.0 2.1.0
      PHP-Erweiterung FTP Ja
      Apache Modul 'mod_rewrite' Ja
      PHP-Erweiterung PDO Ja
      PHP-Erweiterung Intl Ja
      Programmcode Cache Nein
      memory_limit (>= 48M) 48M
      Der fehler betrifft die SQL request : CREATE TABLE `contrexx_module_news_settings_clean` SELECT * FROM `contrexx_module_news_settings` 1and1 entwort : "Nous faisons suite à votre problème d'exécution de votre ligne de commande SQL : CREATE TABLE `contrexx_module_news_settings_clean` SELECT * FROM `contrexx_module_news_settings` Nous vous informons que vous ne pouvez pas exécuter de CREATE TABLE et de SELECT dans la même ligne de commande, nous vous invitons à séparer vos deux commandes par le symbole ";" par exemple".



      In Deusch (google)
      Wir informieren Sie, dass Sie CREATE TABLE und SELECT nicht in derselben Befehlszeile ausführen können. Wir bitten Sie, Ihre beiden Befehle durch das Symbol ";" zum beispiel.


      Was denkst du darüber ?


      vielen Dank fur ihre Hilfe
      Denis





      Kommentar


      • #4
        ################# DEUTSCH ######################

        Hallo Dennis,

        Dein Deutsch klingt doch gut (oder gibt es einen sehr guten Übersetzer? ) :-D Ich antworte trotzdem in Deutsch und Englisch :-)

        Da dieses ein Vorgang innerhalb des Updatevorgang ist und die Systemanforderungen offensichtlich erfüllt werden, muss ich persönlich leider erst mal passen und verweise nochmal an Thomas daeppen und Michael ritt0r :-)

        Ich werde im Laufe des Tages noch etwas ausprobieren. Die Vorbereitungen dafür dauern leider etwas länger, da das nur auf dem Server geht (leider nicht mehr mit XAMPP) :-(
        Ich habe nur DSL6000, da dauert das rauf- und runterladen von Datenmengen leider länger :-(

        Viele Grüße, Markus



        ################# ENGLISH ######################

        Hello Dennis,

        Your German sounds good (or is there a very good translator?) :-D I still answer in German and English :-)

        Since this is a process within the update process and the system requirements are obviously met, I personally have to first pass and refer again to Thomas daeppen and Michael @ Ritt0r :-)

        I will try something else during the day. The preparations for this unfortunately take a little longer, because that is only on the server (unfortunately not with XAMPP) :-(
        I have only DSL6000, as it takes the up and download of data unfortunately longer :-(

        Best regards, Markus
        Viele Grüße Markus
        ... der Römer aus dem ältesten Dorf "Krefeld´s" :-)


        Kenne contrexx V.1, V.2, V.3, V.4... | ... und ab sofort auch V.5 :-)

        Offizieller "cloudrexx Partner" :-)

        Kommentar


        • #5
          This is the result of my attempt to update to 5.0 after 2 trials to the version 5.0.2... no miracle : Updatevorgang...

          Beim Aktualisieren der Komponente downloads.php trat ein Fehler auf.
          Datenbank Fehler bei folgendem SQL Ausdruck:
          UPDATE `contrexx_module_downloads_download_locale` AS downloadlocale LEFT JOIN `contrexx_module_downloads_download` AS download ON (download.`id` = downloadlocale.`download_id`) SET downloadlocale.`file_type` = download.`icon`

          Detailierte Informationen:
          Versuchen Sie das Update erneut auszuführen.

          Sollte derselbe Fehler wieder erscheinen, suchen Sie im Cloudrexx OpenSource Forum nach weiteren Hilfestellungen zu diesem Fehler.
          Falls diesbezüglich nichts bekannt ist, melden Sie dort den Fehler mit den folgenden Angaben:

          Installierte Version: 4.0.0
          Update Version:
          Info: Beim Aktualisieren der Komponente downloads.php trat ein Fehler auf.
          Fehlermeldung:
          Datenbank Fehler bei folgendem SQL Ausdruck:
          UPDATE `contrexx_module_downloads_download_locale` AS downloadlocale LEFT JOIN `contrexx_module_downloads_download` AS download ON (download.`id` = downloadlocale.`download_id`) SET downloadlocale.`file_type` = download.`icon`

          Detailierte Informationen:

          Kommentar


          • #6
            Thomas daeppen
            Michael ritt0r

            Bitte mal schauen...
            Viele Grüße Markus
            ... der Römer aus dem ältesten Dorf "Krefeld´s" :-)


            Kenne contrexx V.1, V.2, V.3, V.4... | ... und ab sofort auch V.5 :-)

            Offizieller "cloudrexx Partner" :-)

            Kommentar


            • #7
              Hi,
              hab genau den gleichen Fehler von Update V4 auf V5.02.
              Bin auch bei 1und1. Gibst hierfür eine Lösung?

              Kommentar


              • #8
                Hmm...

                Thomas daeppen
                Michael ritt0r

                Liegt das an der Updateroutine?
                Viele Grüße Markus
                ... der Römer aus dem ältesten Dorf "Krefeld´s" :-)


                Kenne contrexx V.1, V.2, V.3, V.4... | ... und ab sofort auch V.5 :-)

                Offizieller "cloudrexx Partner" :-)

                Kommentar


                • #9
                  Ich fuhle mich mit meinem problem allein.
                  Wäre ich wirklich alleine mit diesem problem?

                  Kommentar


                  • #10
                    Wie Du siehst, habe ich die Entwickler bereits verlinkt. Ich schreibe den Support aber mit Verweis auf den Updatebereich und weiteres an und hoffe Thomas und / oder Michael melden sich bei uns hier im Forum...
                    Viele Grüße Markus
                    ... der Römer aus dem ältesten Dorf "Krefeld´s" :-)


                    Kenne contrexx V.1, V.2, V.3, V.4... | ... und ab sofort auch V.5 :-)

                    Offizieller "cloudrexx Partner" :-)

                    Kommentar


                    • #11
                      Ich habe das gesehen und danke Ihnen für Ihre Unterstützung.
                      Ich bin überrascht, der Einzige mit diesem Problem zu sein

                      Kommentar


                      • #12
                        Drosi scheint das Problem auch zu haben...
                        -> https://forum.cloudrexx.com/forum/cl...3072#post63072

                        Und er ist auch bei 1und1
                        Viele Grüße Markus
                        ... der Römer aus dem ältesten Dorf "Krefeld´s" :-)


                        Kenne contrexx V.1, V.2, V.3, V.4... | ... und ab sofort auch V.5 :-)

                        Offizieller "cloudrexx Partner" :-)

                        Kommentar


                        • #13
                          Ich werde 1und1 kontaktieren

                          Kommentar


                          • #14
                            Hello DROSI, Hello MK70
                            Können Sie bestätigen, dass ich nicht der einzige 1and1-Client mit diesem Problem bin?

                            Die Informationen reichen nicht aus, um das Problem analysieren zu können
                            Ich werde einen weiteren Test mit einer Datenbanküberwachung durchführen

                            Kommentar


                            • #15
                              Hallo Denis

                              ich kann Dir nichts sicheres bestätigen, aber es kann u.a. am Webhoster liegen. Es braucht ja nur eine kleine aber nötige Ressource, die nicht bei der Systemabfrage zu Beginn eines Updates angezeigt wird, deaktiviert zu sein. Wie gesagt, habe ich auch bei der Umstellung von php5 zu php7 meist eine Nachbearbeitung der Einstellungen vorgenommen.

                              Mit einem anderen Webhoster (war das Hostpoint?) gab es anfangs auch Probs, die scheinbar gelöst wurden - Also besteht Hoffnung. Nur muss die ggf. fehlerhafte Einstellung gefunden werden.
                              Viele Grüße Markus
                              ... der Römer aus dem ältesten Dorf "Krefeld´s" :-)


                              Kenne contrexx V.1, V.2, V.3, V.4... | ... und ab sofort auch V.5 :-)

                              Offizieller "cloudrexx Partner" :-)

                              Kommentar

                              Lädt...
                              X