Ankündigung

Einklappen
Keine Ankündigung bisher.

Weisse Seiten im Backend

Einklappen
X
 
  • Filter
  • Zeit
  • Anzeigen
Alles löschen
neue Beiträge

  • Weisse Seiten im Backend

    Hallo

    Nach einem Umzug auf eine neue Domain kann ich diverse Punkte im Backend nicht mehr bearbeiten. Unter anderem kann ich im Bereich Administration den Punkt Layout & Design nicht mehr aufrufen. Sobald ich den Punkt anklicke erscheint eine weisse Seite.

    Hat jemand eine Idee wie ich das Problem beheben kann?

    Übrigens ich benutze die Version 2.1 mit SP 2

  • #2
    Hallo tomtom31

    Um den Fehler genauer analysieren zu können benötigen wir eine Debugging-Ausgabe.
    Diese kannst Du wie folgt machen:

    1. Öffne die Datei /cadmin/index.php mit einem Text-Editor
    2. Suche nach DBG
    3. Falls dort DBG::deactivate(); steht durch DBG::activate(); ersetzten und die Datei wieder hochladen.

    Die Ausgabe, die beim Klick auf "Layout & Design" nun ausgelöst wird, kannst Du dann hier reinkopieren.

    Sehr wahrscheinlich benötigt der Ordner /themes auf dem neuen Server noch Schreibrechte 775.

    Freundliche Grüsse
    Ueli Kramer

    Kommentar


    • #3
      Hallo Ueli

      Danke für den Tip.

      Wenn ich die Schritte ausführe wie Du es beschrieben hast erscheint bei mir dann folgende Meldung:
      "Fatal error: Call to undefined function ftp_connect() in /var/webhosting/8/688/727/3727688/chroot/home/3727688/htdocs/lib/FRAMEWORK/File.class.php on line 60"

      Weisst Du was das zu bedeuten hat? Ich versteh nur Bahnhof...

      Gruess Tom

      Kommentar


      • #4
        Hallo Tom

        Du hast FTP in den Konfigurationen (config/configuration.php) aktiviert und dein Server unterstützt keine PHP zu FTP Verbindungen.
        Sofern Du Serveradmin bist kannst Du hier nachsehen was man machen müsste, damit eine FTP-Verbindung von Contrexx aus möglich ist: http://ch1.php.net/manual/de/ftp.installation.php

        Die FTP-Verbindung ermöglicht Contrexx ein Schreiben, Hochladen und Bearbeiten von Dateien über FTP. Wenn dies ausgeschaltet wird müssen eventuell die Ordner- und Dateirechte von /images , /tmp , /feed , /media angepasst werden, damit der Upload wieder funktioniert.

        Freundliche Grüsse
        Ueli Kramer

        Kommentar


        • #5
          Hallo Ueli

          Aha, darum die Fehlermeldungen.

          Ich habe die Zeile im configuration.php "$_FTPCONFIG['is_activated'] = false; // Ftp support true or false" angepasst und den FTP Zugriff deaktiviert. Nun funktioniert alles wunderbar.

          Danke für Deine Hilfe!

          Gruess Tom
          Zuletzt geändert von tomtom31; 22.01.2013, 08:40.

          Kommentar

          Lädt...
          X